Upgrading from Ubuntu 13.10 Saucy to 14.04 Trusty – unresolvable problem

I’ve just been trying to upgrade my server/workstation to the latest 14.04 alpha from Ubuntu but became slightly stuck with the standard instructions of:
update-manager –d

Or:
sudo do-release-upgrade -d
I got:
An unresolvable problem occurred while calculating the upgrade.
I’ve got the ppa:xorg-edgers/ppa enabled for my integrated Intel HD 4000 graphics, this is likely my problem so I need to remove all its packages… ppa-purge to the rescue.
sudo ppa-purge ppa:xorg-edgers/ppa
The upgrade is now well under way with hopefully no problems to surface down the road.. 😉

Leave a Reply